Issues with Billing Operations for US Customers

Incident Report for Fathom

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 02:38 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2025 - 23:41 UTC

Identified

We are currently experiencing an issue with billing operations in the US due to an issue with a third-party tax information supplier.
Posted Mar 21, 2025 - 04:18 UTC
This incident affected: Application.