Impacts to payments

Incident Report for Fathom

Resolved

This incident has been resolved.
Posted Mar 26, 2026 - 00:07 UTC

Monitoring

Our downstream payment provider appears to have resolved the issue. We are continuing to monitor payments. Any failed invoice payments will be tried again automatically over the next day.
Posted Mar 24, 2026 - 23:06 UTC

Investigating

We are currently investigating an issue with our payments provider. Attempts to make payments (both subscribing and attempt of monthly invoice payments) for USD, CAD, NZD, GBP, EUR and ZAR currencies will currently fail. AUD is not impacted.
Posted Mar 24, 2026 - 21:02 UTC
This incident affected: Application.