The majority of payment methods have been restored. Only American Express payments for ZAR currency customers are still affected. We are continuing to work with our external providers to rectify the issue.
Posted May 05, 2026 - 04:59 UTC
Update
We have re-enabled payments for American Express cards for all currencies except ZAR. We expect to have ZAR payments online before 1 May.
Posted Apr 24, 2026 - 03:30 UTC
Update
We are awaiting third-party response on the resolution of the issue.
Posted Apr 01, 2026 - 23:46 UTC
Update
We are continuing to investigate this issue.
Posted Mar 31, 2026 - 23:40 UTC
Investigating
We are currently investigating an issue with our downstream payment providers regarding American Express payments. This appears to be affecting all currencies and results in payment failure.