Long load times and timeouts

Incident Report for Fathom

Resolved

This incident has been resolved.
Posted Aug 19, 2025 - 04:05 UTC

Update

We are not expecting any further incidents. Engineers are still actively monitoring services performance.
Posted Aug 18, 2025 - 17:41 UTC

Monitoring

The issue has been identified and we are continuing to monitor the service.
Posted Aug 18, 2025 - 17:04 UTC

Investigating

We are investigating the issue.
Posted Aug 18, 2025 - 16:03 UTC
This incident affected: Application.